Jump to content
Olympus Entertainment - Celebrating 10 Years! [$2k+ GIVEAWAY] ×
Special Promotion [FREE OLYMPUS+] ×

Recommended Posts

I just got a pair of Logitech G430s and I love it and everything except one thing.  Whenever I play cop and I try to talk in direct chat, my sound goes out immediately, then it reconnects  in teamspeak but my in-game sound for arma stays silent.  Does anyone know of a fix for this because as of now I can't play cop and it's getting frustrating :/.

Link to comment

if you mean how to fix ingame mic you have to restart the entire Arma 3 Game to make it work again, sucks indeed. if you mean a general fix im sorry to say i have no idea...

Link to comment
  • Head Admin

Thats strange I've never had a problem like that before.  Is there any kind of Logitech equivalent software like Razer Synapse?  Perhaps you need it running to make full use of a headset like that.  Also make sure you have drivers installed and up to date.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and our Privacy Policy.